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The supplied applications are intended to quickly demonstrate the power and features of Rocket’s 

PASSPORT Host Integration Objects® software (HIO). The sample applications are written in a variety of 

programming languages and the source code is made available for developers.

Each application can has been configured to work with Zephyr’s sample CICS based application, but they 

can be simply modified to to work with a customer’s own host based applications. Table

passport hio–sample applications
There are a number of sample applications supplied with PASSPORT Host Integration Objects (HIO) that 

demonstrate how to use the various features of PASSPORT HIO.

Most of these applications are configured by default to access the Zephyr z/OS mainframe host and 

assume that a connection can be established to this host. The configuration file has the .ZCC file extension 

and may be edited with NOTEPAD.EXE or any text editor. The IPHostName= parameter may be modified to 

point to any mainframe system you have access to. For all other sample applications, the IPHostName= 

parameter in the .ZCC file is empty and will need to be populated with the IP address of the mainframe 

system you want to connect to.

For the VBScript sample, note that some of the functions refer to specific fields or areas of the host screens. 

These functions may need to be modified if connecting to a different host. For the WAHIO sample, changes 

will need to be made to the source and the application will need to be recompiled.

All sample programs, except the Terminal Control sample programs, are written using a model 2 screen 

size. This provides an 80 column by 24 row screen display. In order to use these sample programs with 

larger screen sizes, you must modify the source code to add this capability, and then rebuild the 

application.

working with the supplied hio applications
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c# asp .net server (wahio)

This server based sample program demonstrates how to use PASSPORT Host Integration Objects in C# 

ASP.NET. This is a web application that connects to Rocket's IBM z/OS sample CICS application and 

allows you to search for information within the database.

After the user types text to search for and clicks the "Submit" button, a host session is created at the 

server, then information is retrieved from the host and sent back to the client in an HTML table if 

information is found. When the HTML form is submitted to the server, this ASP.NET application will take 

the following steps to search:

1.  Launch a TN3270E session connecting to the Zephyr mainframe CICS region.

2.  Wait for the main sign-on screen to be displayed.

3.  Send username (CICSU) and password (CICSU) and <ENTER>

4.  Wait for the next screen.
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5.  Send CICS transaction amnu <ENTER>

6.  Wait for the next screen

7.  Depending if the user specified a file number, the application will either

1) Send AINQ and the file number<ENTER>

2) Or Send ABRW<ENTER>

8.   Wait for the next screen.

9.   Screen scraping of the host screen(s).

10.  Disconnect and close the session.

11.  Send back the results in a HTML table format

requirements
The sample application requires the following in order to run:

Windows Server 2003 or later with .NET Framework and ASP.NET installed (Can also work from 

Windows 7 or XP desktop)

Internet Information Services (IIS) installed, configured and running properly

how to install iis and asp.net on windows server 2008
IIS and ASP.NET are not enabled by default when you install Windows Server 2008. Follow the steps below 

to enable these:

1.   Click Start->Administrative Tools and open Server Manager.

2   In the right pane of Server Manager, expand the Roles Summary section and then click Add  

 Roles.

3.  In the Add Roles Wizard, select the Web Server (IIS) check box and then click Next.

4.  In the Role Services step of the Wizard, select the Application Development role service, and  

 then select the ASP.NET check box.

5.  Complete the wizard to install the software.







4  |

how to install the sample application 
1.  Open IIS Manager from the Server Manager or click Start > Administrative Tools > Internet   

 Information Services (IIS) Manager.

2.  On the Connections pane, expand the server node, right-click Default Web Site and then   

 click Add Application. 

   

3.  In the Add Application dialog, set Alias to “WAHIO”. Navigate to the physical path of the   

 WAHIO directory (PASSPORT Host Integration Objects\DotNetServers\CSServer\ by default).  

 Select an application pool for the application and then click OK.

4.  If you are using the 64-bit version of Windows Server, you will need to enable a 32-bit   

 Application Pool in IIS. On the Connections pane, click "Application Pools". Right-click your   

 application pool and select "Advanced Settings...". Change "Enable 32-bit Application" to True.

how to run the sample application 
Open a browser window and navigate to http://<servername>/wahio/default.aspx. Note that the .ZCC 

con�guration �le can be edited to connect to a di�erent host but you may have to make some changes 

to the WAHIO source code and recompile it in order to make it work

vb .net client
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to run the sample application:
1.  Open the PASSPORT Host Integration Objects (default is C:\Program Files\PASSPORT Host   

 Integration Objects\)

2.   Open the sub folder: DotNetClients\VBClient\bin

3.   Double-click on VBClient.exe

OR:

1.  Click on Start->All Programs->PASSPORT Host Integration Objects

2.  Click on Sample Program - VB. Net Client

to open the project in visual studio:
Open the project file VBClient.vbproj in Visual Studio. The default directory that this project is installed 

into is:

C:\Program Files\PASSPORT Host Integration Objects\DotNetCLients\VBClient\

what this sample program does:
This sample application demonstrates how to use (1) the HIO object, and (2) the HIO object in 

conjunction with the Terminal Control object.

When the sample application is started, there is a single menu command: Session. Use the 

Session->Open HIO Client to start a host session using just the HIO object. Use the Session->Open 

Terminal Control Client to start a host session using an HIO object, and also use the Terminal Control 

object to display the session screen.

The configuration file used to define the host connection is LOCIS.ZCC and this file is located in the \bin 

sub folder. This file is text file that can be edited with NOTEPAD.EXE. The host IP address specified in this 

configuration file is our demo mainframe. If the computer you are using to run this sample application 

does not have access to the Internet, the sample application will fail. You may edit this file and change 

the IPHostName= parameter to point to a mainframe system you have access to.
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vbscript–html page

This client based sample web application uses VBScript to test the properties and methods of each 

object. The application connects to our demo mainframe and assumes that a connection can be 

established to this host. If, for some reason, a connection cannot be made to this host, the LOCIS.ZCC �le 

may be edited to connect to a di�erent host. Note that some of the functions refer to speci�c �elds or 

areas of the LOCIS screens. These functions may also need to be modi�ed if connecting to a di�erent 

host.

to run the sample program
1. Open the C:\Program Files\PASSPORT Host Integration Objects\VBScriptSample\ folder.

2.  Double-click on the "VBScript Sample.htm" file

OR:

1.  Click on Start->All Programs->PASSPORT Host Integration Objects

2.  Click on Sample Program - VBScript
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hvisual basic

This client based sample program is a Visual Basic program that references the PASSPORT HIO Type 

Library. It has Menus as follows and uses the events OnSessionChanged, OnScreenChanged and 

OnOIAChanged.d or disconnected:

to run the sample program:
1.  Open the C:\Program Files\PASSPORT Host Integration Objects\VBSample folder.

2.  Double-click on VBHIOTest.exe

OR:

File Sessions Sessions Screen Fields Field Help
Exit New Session

Open Session

Close Session

Update License

Connect

Disconnect

IsConnected

Con�guration Resource

Session Name

Session Type

OIA 

GetString

PutString

Get Rows/Columns

GetCursor

PutCursor

FindString

GetData

SendKeys

SendAid

WaitforStr

WaitforNoX

Count

Item

Refresh

FindByPosition

FindByString

Enum

AboutGetString

PutString
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1.  Click on Start->All Programs->PASSPORT Host Integration Objects

2.  Click on Sample Program - Visual Basic.

to view the source �le

1.  Click on Microsoft Visual Basic 6.0. New Project Dialog appears.

2.  Click on Standard Exe and Existing projects. Browse for the VBHIOTest Program.

3.  Click On VBHIOTest.vbp and click Open.

visual c

:This client based sample program demonstrates how to use PASSPORT Host Integration Objects in Visual 

C++. This sample is a minimized version of terminal emulator with following functionality:

Connecting

Disconnecting

Inputting data

Moving Cursor

Submitting ENTER to interact with the host










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to run the sample program:
1.  Open the C:\Program Files\PASSPORT Host Integration Objects\VCSample folder.ple folder.

2.  Double-click on vchio.exe

OR:

1.  Click on Start->All Programs->PASSPORT Host Integration Objects.

2.  Click on Sample Program - Visual C++.

After the program is opened, click File->Open to open one .ZCC �le with all the host information, it will 

start connecting to the host and host screen will be automatically updated through event handling. You 

can navigate host screens by typing data and hitting ENTER key.

.ZCC File Format

terminal control – html page
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This sample HTML page shows how to create four Terminal Control objects and connect them to the 

same PASSPORT HIO session object. This HTML page displays four views of the same session. The session 

connects to the demo mainframe system. The con�guration �le used for the HIO session object is 

Locis.zcc. This �le and the sample HTML page passterm.htm are located in the folder C:\Program 

Files\PASSPORT Host Integration Objects\TermControlSample\ . The document that stores the keyboard 

and screen display attribute information for the terminal object is passterm.zws and is stored in the 

C:\Program Files\PASSPORT Host Integration Objects\ folder.

to display the sample html page:
1.  Open the C:\Program Files\PASSPORT Host Integration Objects\TermControlSample\ folder.

2.  Double-click on passterm.htm

OR

1.  Click on Start->All Programs->PASSPORT Host Integration Objects

2.  Click on Terminal Control Sample - HTML Page.+

to view the source �le:
1.  View the passterm.htm �le in Internet Explorer

2.  Use the View->Source menu command to look at the actual HTML code

.
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terminal control - visual basic

This client based sample program is a Visual Basic program that shows how to use the PASSPORT terminal 

object in conjunction with a PASSPORT HIO session object. The sample program connects to the host 

mainframe system. The con�guration �le used for the HIO session object is LOCIS.zcc. This �le and the 

executable �le TermClient.exe are located in the C:\Program Files\PASSPORT Host Integration 

Objects\TermControlSample\ folder. The document that stores the keyboard and screen display attribute 

information for the terminal object is passterm.zws and is stored in the C:\Program Files\PASSPORT Host 

Integration Objects\ folder.

to run the sample program:
1.  Open the C:\Program Files\PASSPORT Host Integration Objects\TermControlSampl\ folder.

2.  Double-click on TermClient.exe

OR

1.  Click on Start->All Programs->PASSPORT Host Integration Objects

to view the source �le:
1. Click on Microsoft Visual Basic New Project Dialog appears.

2.  Click on Standard Exe and Existing projects. Browse for the TermControlSample folder.

3, Click on Project1.vbp and click Open.
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hints and tips: how to hide browser toolbars

For your custom AutoHTML application, you may wish to present the application inside the browser 
window with all toolbars disabled. Below is sample JavaScript code to accomplish this:

.

<html>

<head> 
<!-- saved from url=(0014)about:internet --> 
<meta http-equiv="Content-Type"content="text/html;charset=iso-8859-1">
 <script language="JavaScript">
 <!-- 
function LaunchNoToolbar()
  { 
                    window.open ('https://dr.zephyrcorp.com/autohtml/', '_blank', con�g='toolbar=no')
con�g='toolbar=no')
  }
 -->
 </script>
 </head> <body> 
 <a href="javascript:LaunchNoToolbar()">Launch HIOAutoHTML</a>
 </body>
 </html>
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