Rocket Device Adapter Pack for IBM Spectrum Protect Snapshot is a plug-in for IBM Spectrum Protect Snapshot. With Rocket Device Adapter Pack for IBM Spectrum Protect Snapshot, you can back up files located in your non-IBM storage systems to expand your disaster recovery options and increase data availability. Supported storage device vendors include EMC, Hitachi Data Systems, HP, Huawei, and NetApp.

With Rocket Device Adapter Pack for IBM Spectrum Protect Snapshot, you can take advantage of IBM Spectrum Protect Snapshot advanced snapshot-based data protection capabilities for application data on EMC, Hitachi Data Systems (HDS), HP, Huawei, and NetApp storage devices.

You can also leverage features such as EMC TimeFinder/Snap, TimeFinder/Clone, VP Snap and VP Clone, VNX Snapshots, SnapView, and SnapView Clone, XtremIO Virtual Copies (XVC), HDS ThinImage and ShadowImage, HP 3Par Virtual and Full Copy, Huawei OceanStor LUN and File System Snapshot, OceanStor LUN Clone, and NetApp Snapshot for both FlexVols and Infinite Volumes.

Compatibility matrix
Storage Device and Architecture Backups Types
Vendor Model Interface Snapshot Clone Remote
EMC VMAX and DMX storage devices as supported by Solutions Enabler 7.5, 8.0, and 8.1 (Symmetrix, VMAX2/VMAX3, only SAN) TimeFinder Snap / SnapVP / SnapVX (through SnapVP, space-efficient) TimeFinder Clone FULL Copy / Clone INCR Copy / Clone NOCOPY Symmetrix Remote Data Facility, SRDF Remote Snapshot (SRDF pairs should already exist)
VNX storage devices as supported by NaviSecCLI 7.33 (only SAN) VNX Snapshot (space-efficient), SnapView Snapshot (copy-on-first-write, reserves ~20%) SnapView Clone FULL Copy / INCR Copy X
XtremIO (with or without VPLEX v5.3 or later) storage devices v4.0 or later, XtremIO REST API v2.0 (only SAN) XtremIO Virtual Copies (snapshot on a snapshot set) X X
Hitachi HDS VSP, USP, HUS and HUS VM devices as supported by HDS CCI 1-30-03 or later (optionally, Device Manager v7.6 or v8.0, only SAN) Thin image Shadow Image FULL Copy / INCR Copy Can coexist with mirror link - but only performs local replication
NetApp NetApp Storage Systems as supported by NetApp Data ONTAP 8.1 or later 8.x (only NetApp clustered Data ONTAP, SAN&NAS) Snapshot capability of NetApp for FlexVols and Infinite Volumes X Remote Snapshot of NetApp SnapMirror
HP 3PAR storage devices as supported by HP 3PAR Remote CLI v3.2 (only SAN) Virtual Copy (snapshots of a list of Virtual Volumes) Physical Copy Full Copy / Incremental Copy of a list of Virtual Volumes X
Huawei OceanStor V3, V5 series, and OceanStor Dorado V3 series of devices as supported by OceanStor REST API v1.0 (SAN & NAS) OceanStor LUN and File System Snapshots OceanStor LUN Clones X
System Requirements

Rocket Device Adapter Pack for IBM Spectrum Protect Snapshot has the following software requirements:

  • Operating systems supported: AIX, Linux, Solaris, and HP-UX.
  • IBM Spectrum Protect Snapshot for AIX, Linux, Solaris, and VMware. The minimum required version is 4.1.0.0.
  • For AIX, Java version 1.7 or later.

Requirements for the Adapter for HP 3Par storage systems:

  • IBM Spectrum Protect Snapshot for AIX, Linux, Solaris, and HP-UX. The minimum required version is 4.1.0.2.
  • HP 3Par CLI 3.2. Contact your HP representative for more information.
  • IBM Spectrum Protect Snapshot for VMware. The minimum required version is 4.1.0.1 and APAR fix IT03252, or a later version.

Requirements for the Cluster adapter for NetApp storage systems:

  • IBM Spectrum Protect Snapshot 4.1.0.0 or later for AIX, Linux, Solaris, and VMware.
  • NetApp DATA ONTAP 8.1 or later on the storage array.

Additional NetApp consistency group support for the Cluster adapter for NetApp storage systems has the following requirements:

  • IBM Spectrum Protect Snapshot 4.1.4.0 or later for AIX, Linux, Solaris, and VMware.
  • For NetApp consistency group support, Java version 1.8 or later is required.

Requirements for the Adapter for EMC Symmetrix storage systems:

  • IBM Spectrum Protect Snapshot for AIX, Linux, Solaris, and VMware. The minimum required version is 4.1.0.0.
  • EMC Symmetrix Command Line Interface SYMCLI adapter versions 7.5 through 8.1 are supported. Contact your EMC representative for more information.

Requirements for the Adapter for EMC VNX storage systems:

  • IBM Spectrum Protect Snapshot for AIX, Linux, and Solaris. The minimum required version is 4.1.0.2.
  • EMC NaviSecCLI software version 7.33. Contact your EMC representative for more information.
  • IBM Spectrum Protect Snapshot for VMware. The minimum required version is 4.1.0.1 and APAR fix IT03252, or a later version.
  • VNX Snapshots feature enabler on the storage device for usage of VNX Snapshots.
  • VNX SnapView feature enabler on the storage device for usage of VNX SnapView Snaps and Clones.

Requirements for the Adapter for EMC XtremIO storage systems:

  • IBM Spectrum Protect Snapshot 4.1.0.2 or later for AIX, Linux, and Solaris.
  • The EMC VPLEX (if used) must have software version 5.3 or later.
  • The EMC XtremIO must support the REST API version 2.0.
  • The EMC XtremIO must have Storage Array Version 4.0 or later.
  • IBM Spectrum Protect Snapshot for VMware. The minimum required version is 4.1.0.1 and APAR fix IT03252, or a later version.

Requirements for the Adapter for HDS storage systems:

Requirements for the Adapter for Huawei OceanStor storage systems:

  • IBM Spectrum Protect Snapshot 4.1.0.2 or later for AIX, Linux, and Solaris.
  • The Huawei OceanStor storage systems must support the REST API version 1.0. Contact your Huawei representative for more information.
  • IBM Spectrum Protect Snapshot for VMware. The minimum required version is 4.1.0.1 and APAR fix IT03252, or a later version.